Sorun Cevaplayalım

İşinizle ilgili öngörüler edinin, gerçek zamanlı bilgilere göre karar alın.

SAP Eğitim ve Sertifika Dönemleri

Uzmanlığınızı ve deneyiminizi SAP çözümleri kullanarak tasdik edin.

Çözüm Ekibi Başvurusu

Kullanıcılara hızlı ve pratik çözümler üreterek görev almak isteyenler.

SAP BLOG Errors faced while posting values in BPC Optimized for SAP S/4 HANA 1610 after Service Pack Upgrade

SAP Blog

Kayıtlı Üye
Katılım
22 Ara 2017
Mesajlar
997
Tepki puanı
6
Introduction:

After upgrading the Service Pack of SAP S/4 HANA 1610 from Service Pack 03 to Service Pack 07, we faced an issue where we were unable to load data into the Info Providers using Planning Templates and Input Ready Queries. In this blog I have mentioned the problem that I had faced and the solution for the same.

Main Problem:

After Service pack upgrade, I executed an Input ready Query in the T-Code RSRT and tried posting few values into it. But the values didn’t get saved and once after clicking the ‘Save’ button, the values disappeared. I have mentioned the step by step procedure in the below screenshots.

  1. Go to the T – code RSRT, type the name of any Input Ready Query as mentioned in the below screenshot and click on execute.
  2. Enter the Fiscal Year and Posting period and Execute it.
  3. The following screen appears after executing the report.
  4. I have entered the amount 200.0000 against JUN 2019 and Clicked on Save Button.
  5. You can observe that the values don’t get saved in the report.

Here, we were unable to sort out the issue, since the system didn’t show any error message in the screen, but the values didn’t get posted. The system was just showing a warning that the selected period was not input ready. We tried checking if the Input Ready Check box has been enabled in the Query Designer against the Key figures that need to be planned. But, all of them were fine and so we had to check if the Models were active. This is when we had tried the below solution.

Solution:

  1. Go to the T-Code RTCMD.
  2. Type the Model Name RTCCTB and display it.
  3. Click on ‘Activate’ in order to ensure that the model is active.
  4. Then, click on ‘Generate Views’ to ensure that the Column views are generated.
  5. Now, click on ‘More’ and then select ‘Utilities’. In the ‘Utilities’ section, click on ‘Renew Posting API’, to generate the code according to the structure of ACDOCC.
  6. Now, again go to the T-code RSRT and follow the steps mentioned in the Main Problem Section. After completing the Step-5 mentioned in the Main Problem Section, you can find that the values get posted.



Hence, the problem is solved.

Conclusion:

So, from this blog post you could have got an idea on how the issue in Posting values after Service Pack upgrade can be rectified. Kindly share your solutions if you have come across similar kind of issues and post your comments.

Reference:

  • Finalizing and Activating RTC Model from the link provided below: SAP Help Portal

Okumaya devam et...
 
Üst